This isn't the Exploit Development Course

If you are looking for the exploit development course, it is located here

I highly recommend you do this course first, but if you aren't sure, check the pre-requisites over there.